summaryrefslogtreecommitdiff
path: root/hosts/abbenay/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/abbenay/hardware-configuration.nix')
-rw-r--r--hosts/abbenay/hardware-configuration.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/hosts/abbenay/hardware-configuration.nix b/hosts/abbenay/hardware-configuration.nix
new file mode 100644
index 0000000..876431d
--- /dev/null
+++ b/hosts/abbenay/hardware-configuration.nix
@@ -0,0 +1,35 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "sd_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/ba8853b3-6e52-49d6-a250-6d99b8dfe6d6";
+ fsType = "ext4";
+ };
+ fileSystems."/home" =
+ { device = "/dev/disk/by-label/nix-space";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/0F28-FE85";
+ fsType = "vfat";
+ };
+
+ swapDevices = [
+ { device = "/dev/disk/by-uuid/6e9fddfc-99d2-46d2-bcb4-d8c5e1c19d38"; }
+ ];
+
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}