summaryrefslogtreecommitdiff
path: root/home/packages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/packages.nix')
-rw-r--r--home/packages.nix15
1 files changed, 4 insertions, 11 deletions
diff --git a/home/packages.nix b/home/packages.nix
index c7ab5f2..b2f5997 100644
--- a/home/packages.nix
+++ b/home/packages.nix
@@ -1,4 +1,4 @@
-{ config, lib, pkgs, inputs, ... }:
+{ config, lib, pkgs, inputs, system, ... }:
let
naersk = pkgs.callPackage inputs.naersk {};
@@ -21,15 +21,6 @@ in
#!/usr/bin/env bash
exec ${pkgs.nixFlakes}/bin/nix --experimental-features "nix-command flakes" "$@"
'')
- # never version of unison for playing around
- (unison-ucm.overrideAttrs (old: rec {
- milestone_id = "M2g";
- version = "1.0.${milestone_id}-alpha";
- src = fetchurl {
- url = "https://github.com/unisonweb/unison/releases/download/release/${milestone_id}/ucm-linux.tar.gz";
- sha256 = "004jx7q657mkcrvilk4lfkp8xcpl2bjflpn9m2p7jzlrlk97v9nj";
- };
- }))
# internet apps & clients
firefox thunderbird keepassxc chromium signal-desktop mumble lynx
openconnect matterhorn
@@ -66,7 +57,9 @@ in
# rust
rls cargo rustc rust-analyzer rustfmt
# others
- gcc nixfmt niv cachix julia_16-bin python39
+ gcc cachix julia_16-bin python39
+ # nix things
+ nixfmt niv inputs.deploy-rs.defaultPackage.${system}
# isabelle
(import "${inputs.playground.outPath}/isabelle-nix-fhsenv" {inherit pkgs; })
# (import /home/stuebinm/projects/isabelle-utils {}).isabat