summaryrefslogtreecommitdiff
path: root/flora/services/znc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/znc.nix')
-rw-r--r--flora/services/znc.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/flora/services/znc.nix b/flora/services/znc.nix
new file mode 100644
index 0000000..e81bc65
--- /dev/null
+++ b/flora/services/znc.nix
@@ -0,0 +1,43 @@
+{ config, lib, pkgs, ... }:
+
+{
+ services.znc = {
+ enable = true;
+ mutable = false;
+ useLegacyConfig = false;
+ openFirewall = true;
+
+ config = {
+ LoadModule = [ "adminlog" "webadmin" ];
+ Listener.l = {
+ IPv4 = true;
+ IPv6 = false;
+ AllowIRC = true;
+ AllowWeb = true;
+ Port = 12345;
+ SSL = true;
+ };
+ User.stuebinm = {
+ Admin = true;
+ BindHost = "0.0.0.0";
+ LoadModule = [ "chansaver" "controlpanel" "sasl" ];
+ QuitMsg = "fell into a looping fixpoint operator";
+ RealName = "stuebinm";
+ Pass.password = {
+ Method = "sha256";
+ Hash = "a0dd4be1f8959dc9c775a76779bfb8fab52e43b89bad24d85bdc28caa3499710";
+ Salt = "eNT_:x1SgMvQNJAW0J!Q";
+ };
+ Network.libera = {
+ IRCConnectEnabled = true;
+ LoadModule = [ "simple_away" "sasl" ];
+ Server = [ "irc.libera.chat +6697" ];
+ TrustAllCerts = false;
+ TrustPKI = true;
+ };
+ };
+ };
+ };
+
+ networking.firewall.allowedTCPPorts = [ 12345 ];
+}