summaryrefslogtreecommitdiff
path: root/flora/services/urlwatcher.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/urlwatcher.nix')
-rw-r--r--flora/services/urlwatcher.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/flora/services/urlwatcher.nix b/flora/services/urlwatcher.nix
new file mode 100644
index 0000000..56e043a
--- /dev/null
+++ b/flora/services/urlwatcher.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+
+{
+ systemd.services.urlwatcher-ilztal = {
+ enable = true;
+ description = "script watching the ilztalbahn gtfs for changes";
+ wantedBy = [ "multi-user.target" ];
+ after = [ "network.target" ];
+ serviceConfig.Type = "simple";
+ path = [ pkgs.git ];
+ script = ''
+ ${pkgs.gauche}/bin/gosh ${pkgs.copyPathToStore ./urlwatcher.scm}
+ '';
+ };
+
+ systemd.timers.wikibot = {
+ wantedBy = [ "timers.target" ];
+ timerConfig = {
+ Unit = "urlwatcher-ilztal.service";
+ OnBootSec = "5h";
+ OnActiveSec = "1d";
+ };
+ };
+}