summaryrefslogtreecommitdiff
path: root/flora/services/surveys.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/surveys.nix')
-rw-r--r--flora/services/surveys.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/flora/services/surveys.nix b/flora/services/surveys.nix
deleted file mode 100644
index befa673..0000000
--- a/flora/services/surveys.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{pkgs, config, ...}:
-
-let survey = pkgs.fetchgit {
- url = "https://stuebinm.eu/git/slightly-better-surveys";
- rev = "c255269db0c739400b62d4c4041e3238b1045d22";
- sha256 = "007q6s5xc3kn3dy1zj7hc94wyn495qam2x1020br3crwgpxy3hmp";
- };
-in
-{
- services.nginx.virtualHosts."survey.stuebinm.eu" = {
- locations."/".root = survey.outPath + "/site";
- locations."/upload".proxyPass = "http://localhost:8080";
-
- enableACME = true;
- forceSSL = true;
- };
-
- services.nginx.appendHttpConfig = ''
- types {
- application/wasm wasm;
- }
- '';
-}