summaryrefslogtreecommitdiff
path: root/flora/services/picarones.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/picarones.nix')
-rw-r--r--flora/services/picarones.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/flora/services/picarones.nix b/flora/services/picarones.nix
new file mode 100644
index 0000000..c2e3c7b
--- /dev/null
+++ b/flora/services/picarones.nix
@@ -0,0 +1,26 @@
+{config, pkgs, ...}:
+let
+ source = builtins.fetchGit {
+ url = "https://stuebinm.eu/git/picarones/";
+ rev = "0596b9f6c561daa67945adb81570efd30650dffd";
+ };
+in
+{
+
+ imports = [ source.outPath ];
+
+ services.picarones = {
+ enable = true;
+ frontend = {
+ enable = true;
+ domain = "picarones.stuebinm.eu";
+ proxyBackend = true;
+ config = {
+ enableACME = true;
+ forceSSL = true;
+ };
+ };
+ };
+
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+}