summaryrefslogtreecommitdiff
path: root/flora/services/mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/mail.nix')
-rw-r--r--flora/services/mail.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/flora/services/mail.nix b/flora/services/mail.nix
new file mode 100644
index 0000000..d41f0e8
--- /dev/null
+++ b/flora/services/mail.nix
@@ -0,0 +1,26 @@
+{ config, lib, pkgs, inputs, ... }:
+
+{
+ imports = [ inputs.simple-nixos-mailserver.nixosModule ];
+
+
+
+ mailserver = {
+ enable = true;
+ fqdn = "mail.stuebinm.eu";
+ domains = [ "stuebinm.eu" ];
+
+ # A list of all login accounts. To create the password hashes, use
+ # nix run nixpkgs.apacheHttpd -c htpasswd -nbB "" "super secret password" | cut -d: -f2
+ loginAccounts = {
+ "hello@stuebinm.eu" = {
+ hashedPasswordFile = "/var/mailstate/hello-password";
+ aliases = ["postmaster@stuebinm.eu" "abuse@stuebinm.eu"];
+ };
+ };
+
+ # Use Let's Encrypt certificates. Note that this needs to set up a stripped
+ # down nginx and opens port 80.
+ certificateScheme = 3;
+ };
+}