summaryrefslogtreecommitdiff
path: root/flora/services/cgit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/cgit.nix')
-rw-r--r--flora/services/cgit.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flora/services/cgit.nix b/flora/services/cgit.nix
index 094bfd5..cc05d5c 100644
--- a/flora/services/cgit.nix
+++ b/flora/services/cgit.nix
@@ -12,6 +12,11 @@
isReadOnly = true;
};
+ bindMounts."/forks" = {
+ hostPath = "/var/git/forks";
+ isReadOnly = true;
+ };
+
config = {pkgs, config, ...}: {
services.lighttpd.enable = true;
services.lighttpd.extraConfig = ''server.use-ipv6 = "enable"'';
@@ -67,6 +72,9 @@
cache-scanrc-ttl=1
scan-path=/git
+
+ section=Forks
+ scan-path=/forks
'';
};