summaryrefslogtreecommitdiff
path: root/flora/services/akkoma.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/akkoma.nix')
-rw-r--r--flora/services/akkoma.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/flora/services/akkoma.nix b/flora/services/akkoma.nix
index 5a2c8f3..756f2a7 100644
--- a/flora/services/akkoma.nix
+++ b/flora/services/akkoma.nix
@@ -26,11 +26,12 @@ in
isReadOnly = true;
};
- config = {pkgs, config, ...}: {
+ config = {config, ...}: {
# generating the manual will fail when mixing nixos channels,
# so disable it here or this won't build at all.
documentation.enable = false;
+ nixpkgs.pkgs = pkgs;
system.stateVersion = "22.11";
@@ -39,9 +40,7 @@ in
frontends = {
primary = {
- package = pkgs.akkoma-frontends.akkoma-fe.overrideAttrs (old: {
- patches = [ ./akkoma-fe-toki-pona.patch ];
- });
+ package = pkgs.akkoma-fe;
name = "pleroma-fe";
ref = "stable";
};
@@ -52,10 +51,6 @@ in
};
};
- package = pkgs.akkoma.overrideAttrs (old: {
- patches = [ ./akkoma-toki-pona.patch ];
- });
-
extraStatic."static/terms-of-service.html" = pkgs.writeText "terms-of-service-html" ''
<p>toki!</p>
<p>lawa kepeken pi tomo akkoma ni li lili: sina li mi la, sina ken kepeken e tomo ni.</p>
@@ -81,6 +76,10 @@ in
description = "a test instance";
email = "dings@dings";
};
+ ":restrict_unauthenticated" = {
+ timelines = true;
+ activities = true;
+ };
":media_proxy" = {
enabled = false;
redirect_on_failure = true;