summaryrefslogtreecommitdiff
path: root/flora/services/akkoma.nix
diff options
context:
space:
mode:
authorstuebinm2024-03-05 03:05:17 +0100
committerstuebinm2024-03-05 03:05:17 +0100
commitc11127995defe25c8b4164389750672a25e61fc0 (patch)
tree7b68c10dfd88fb401448d6bbfab3288df7b5afc1 /flora/services/akkoma.nix
parent911e1fd4986c0556321457a5606f0e747ef556c6 (diff)
restructure & general cleanup
- pkgs/ should now also contain all package overrides - pkgs/patches/ now contains all patches - nix flake info succeeds again - still not sure what to do about scripts - services which are not used should not be kept around this long
Diffstat (limited to 'flora/services/akkoma.nix')
-rw-r--r--flora/services/akkoma.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/flora/services/akkoma.nix b/flora/services/akkoma.nix
index 5a2c8f3..756f2a7 100644
--- a/flora/services/akkoma.nix
+++ b/flora/services/akkoma.nix
@@ -26,11 +26,12 @@ in
isReadOnly = true;
};
- config = {pkgs, config, ...}: {
+ config = {config, ...}: {
# generating the manual will fail when mixing nixos channels,
# so disable it here or this won't build at all.
documentation.enable = false;
+ nixpkgs.pkgs = pkgs;
system.stateVersion = "22.11";
@@ -39,9 +40,7 @@ in
frontends = {
primary = {
- package = pkgs.akkoma-frontends.akkoma-fe.overrideAttrs (old: {
- patches = [ ./akkoma-fe-toki-pona.patch ];
- });
+ package = pkgs.akkoma-fe;
name = "pleroma-fe";
ref = "stable";
};
@@ -52,10 +51,6 @@ in
};
};
- package = pkgs.akkoma.overrideAttrs (old: {
- patches = [ ./akkoma-toki-pona.patch ];
- });
-
extraStatic."static/terms-of-service.html" = pkgs.writeText "terms-of-service-html" ''
<p>toki!</p>
<p>lawa kepeken pi tomo akkoma ni li lili: sina li mi la, sina ken kepeken e tomo ni.</p>
@@ -81,6 +76,10 @@ in
description = "a test instance";
email = "dings@dings";
};
+ ":restrict_unauthenticated" = {
+ timelines = true;
+ activities = true;
+ };
":media_proxy" = {
enabled = false;
redirect_on_failure = true;