summaryrefslogtreecommitdiff
path: root/flora/services/akkoma.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/akkoma.nix')
-rw-r--r--flora/services/akkoma.nix24
1 files changed, 2 insertions, 22 deletions
diff --git a/flora/services/akkoma.nix b/flora/services/akkoma.nix
index 688b5ec..3d031ee 100644
--- a/flora/services/akkoma.nix
+++ b/flora/services/akkoma.nix
@@ -2,13 +2,6 @@
let
- unstable = import inputs.nixpkgs-unstable {
- inherit system;
- overlays = [ (self: super: rec {
- beamPackages = super.beam.packagesWith super.erlang_nox;
- elixir = beamPackages.elixir_1_13;
- }) ];
- };
staticDir = "/var/lib/akkoma/static";
inherit ((pkgs.formats.elixirConf {}).lib) mkAtom mkTuple;
in
@@ -39,32 +32,19 @@ in
# so disable it here or this won't build at all.
documentation.enable = false;
- imports = [
- ("${inputs.nixpkgs-unstable}/nixos/modules/services/web-apps/akkoma.nix")
- ];
-
- # the pleroma_ctl wrapper uses pkgs.elixir, which without this is not the same
- # as akkoma's elixir
- nixpkgs.overlays = [
- (self: super: {
- elixir = unstable.beamPackages.elixir_1_13;
- })
- ];
-
system.stateVersion = "22.11";
services.akkoma = {
enable = true;
- package = unstable.akkoma;
frontends = {
primary = {
- package = unstable.akkoma-frontends.akkoma-fe;
+ package = pkgs.akkoma-frontends.akkoma-fe;
name = "pleroma-fe";
ref = "stable";
};
admin = {
- package = unstable.akkoma-frontends.admin-fe;
+ package = pkgs.akkoma-frontends.admin-fe;
name = "admin-fe";
ref = "stable";
};