summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 9bfce9b..0d902d1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,17 +2,15 @@
description = "testing nix flakes for server deployment";
inputs = {
- nixpkgs.url = "github:NixOS/nixpkgs/release-22.11";
+ nixpkgs.url = "github:NixOS/nixpkgs/release-23.05";
nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
- home-manager.url = "github:nix-community/home-manager/release-22.11";
+ home-manager.url = "github:nix-community/home-manager/master";
home-manager.inputs.nixpkgs.follows = "nixpkgs";
deploy-rs.url = "github:serokell/deploy-rs";
deploy-rs.inputs.nixpkgs.follows = "nixpkgs";
simple-nixos-mailserver.url =
"gitlab:simple-nixos-mailserver/nixos-mailserver/master";
- emacs-overlay.url =
- "gitlab:nix-community/emacs-overlay?rev=d938b780a3d8072aeac0178c46121060079ff217";
rust-overlay.url = "github:oxalica/rust-overlay";
rust-overlay.inputs.nixpkgs.follows = "nixpkgs";
sops-nix.url = "github:Mic92/sops-nix";
@@ -134,7 +132,7 @@
inherit (nixpkgs)
galmon-core galmon-full glitchtip typst almanac
kijetesantakaluotokieni showrt isabelle-utils isabat emacs29
- crs-tools travelynx;
+ travelynx crs-tracker crs-php bahnhof-name;
};
nixosModules = { glitchtip = import ./modules/glitchtip.nix; };