summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..069fcfd
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+
+{
+ description = "testing nix flakes for server deployment";
+
+ inputs = {
+ nixpkgs = "github:NixOS/nixpkgs#release-21.11";
+ nixpkgs-unstalbe = "github:NixOS/nixpkgs#nixpkgs-unstable";
+ uplcg = "git:https//stuebinm.eu/git/uplcg";
+ woitb = "git:https://stuebinm.eu/git/woitb";
+ workadventure = "git:https://stuebinm.eu/git/workadventure-nix";
+ };
+
+ output = { self, nixpkgs, ... }@inputs: {
+
+ nixosConfigurations.chaski = nixpkgs.lib.nixosSystem {
+ system = "x86_64-linux";
+ modules = [ ./hosts/chaski/configuration.nix ];
+ };
+ };
+}