summaryrefslogtreecommitdiff
path: root/cyberbox/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cyberbox/configuration.nix')
-rw-r--r--cyberbox/configuration.nix34
1 files changed, 23 insertions, 11 deletions
diff --git a/cyberbox/configuration.nix b/cyberbox/configuration.nix
index 7bac46a..8e36ed0 100644
--- a/cyberbox/configuration.nix
+++ b/cyberbox/configuration.nix
@@ -42,27 +42,39 @@
# Enable the X11 windowing system.
- services.xserver.enable = true;
+ # services.xserver.enable = true;
# entrypoint for emacs configured with home-manager
# (must be available on the user's $PATH)
- services.xserver.windowManager.session = pkgs.lib.singleton {
- name = "exwm";
- start = "emacs -l ${pkgs.writeText "emacs-exwm-load" ''
- (require 'exwm-config)
- (exwm-config-default)
- (defvar inexwm t)
- ''}";
+ # services.xserver.windowManager.session = pkgs.lib.singleton {
+ # name = "exwm";
+ # start = "emacs -l ${pkgs.writeText "emacs-exwm-load" ''
+ # (require 'exwm-config)
+ # (exwm-config-default)
+ # (defvar inexwm t)
+ # ''}";
+ # };
+
+ services.greetd = {
+ enable = true;
+ settings.default_session = {
+ command = "hikari -c ~/hikari.conf";
+ user = "stuebinm";
+ };
+ restart = false;
};
-
-
+ hardware.opengl.enable = true;
+ fonts.enableDefaultFonts = true;
+ programs.xwayland.enable = false;
+ # xdg.portal.extraPortals = [ pkgs.xdg-desktop-portal-wlr ];
+ # xdf.portal.enable = true;
# Enable sound.
sound.enable = true;
hardware.pulseaudio.enable = true;
# Enable touchpad support (enabled default in most desktopManager).
- services.xserver.libinput.enable = true;
+ # services.xserver.libinput.enable = true;
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions