summaryrefslogtreecommitdiff
path: root/common/headless.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/headless.nix')
-rw-r--r--common/headless.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/common/headless.nix b/common/headless.nix
index 25c668b..396ded0 100644
--- a/common/headless.nix
+++ b/common/headless.nix
@@ -18,8 +18,10 @@
services.openssh = {
enable = true;
- permitRootLogin = "prohibit-password";
- passwordAuthentication = false;
+ settings = {
+ PermitRootLogin = "prohibit-password";
+ PasswordAuthentication = false;
+ };
};
security.sudo.enable = false;
@@ -35,7 +37,7 @@
bantime-increment.enable = true;
bantime-increment.overalljails = true;
bantime-increment.maxtime = "1312m";
- ignoreIP = [ "185.39.64.13" ];
+ maxretry = 20;
};
services.logrotate = {