summaryrefslogtreecommitdiff
path: root/chaski/services/conduit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'chaski/services/conduit.nix')
-rw-r--r--chaski/services/conduit.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/chaski/services/conduit.nix b/chaski/services/conduit.nix
new file mode 100644
index 0000000..022863c
--- /dev/null
+++ b/chaski/services/conduit.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, ... }:
+
+{
+ services.matrix-conduit = {
+ enable = true;
+
+ extraEnvironment.RUST_BACKTRACE = "yes";
+ settings.global = {
+ server_name = "conduit.stuebinm.eu";
+ trusted_servers = [ ]; # TODO what does this mean?
+ port = 6167;
+ allow_registration = false;
+ };
+
+ };
+
+ services.nginx.virtualHosts."conduit.stuebinm.eu" = {
+ locations."/_matrix/".proxyPass = "http://localhost:6167";
+ enableACME = true;
+ forceSSL = true;
+ listen = [
+ {
+ addr = "[::]";
+ port = 443;
+ ssl = true;
+ }
+ {
+ addr = "[::]";
+ port = 8448;
+ ssl = true;
+ }
+ ];
+ };
+
+ networking.firewall.allowedTCPPorts = [ 8448 ];
+}