summaryrefslogtreecommitdiff
path: root/surl-tesh-echer/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2022-02-04 16:07:14 +0000
committerstuebinm2022-08-02 15:43:54 +0200
commit88db2ddd23bdaffd982c7d0c685dce5d57f709b2 (patch)
tree2a54a44c0ef33a61a366336011f1bf1139a15469 /surl-tesh-echer/configuration.nix
parent10b75cc294d416505bde93db98265903a3893b5f (diff)
init surl-tesh-echer
Diffstat (limited to 'surl-tesh-echer/configuration.nix')
-rw-r--r--surl-tesh-echer/configuration.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/surl-tesh-echer/configuration.nix b/surl-tesh-echer/configuration.nix
new file mode 100644
index 0000000..89f2bdf
--- /dev/null
+++ b/surl-tesh-echer/configuration.nix
@@ -0,0 +1,35 @@
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [
+ ./hardware-configuration.nix
+ ];
+
+ # Use the GRUB 2 boot loader.
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/sda";
+
+ networking.hostName = "surl-tesh-echer"; # Define your hostname.
+ # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
+
+ # Set your time zone.
+ time.timeZone = "Europe/Amsterdam";
+
+ networking.useDHCP = false;
+ networking.interfaces.enp0s25.useDHCP = true;
+ networking.interfaces.wlp3s0.useDHCP = true;
+ networking.interfaces.wwp0s20u4i6.useDHCP = true;
+
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "20.09"; # Did you read the comment?
+
+}
+