summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
authorstuebinm2024-06-04 21:14:49 +0200
committerstuebinm2024-06-04 21:14:49 +0200
commitd27e67743931d352e5857b605d44657668fa9013 (patch)
treebad8f97e5f47e791f7f6a3e0b94ef45b5ff0e131 /pkgs/overlay.nix
parent9bf026e55b72af7aa14096440537fefddc56c212 (diff)
all: jump to nixpkgs 24.05
this does a lot of things, most of which are maintenance: - sources update - adjust newly-renamed options - swap some packages that were removed / renamed - update nomsring to newer default ghc - remove the deprecated lib.mdDoc from modules/*.nix - disable the nixpkgs mollysocket module so my own keeps evaluating - bundle the package definition of hikari & wlroots 0.15, which nixpkgs has removed as unmaintained (in fairness, they are unmaintained)
Diffstat (limited to 'pkgs/overlay.nix')
-rw-r--r--pkgs/overlay.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 53e8022..5379bbf 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -34,11 +34,6 @@ in
galmon-core = self.callPackage ./galmon.nix {};
galmon-full = self.callPackage ./galmon.nix { buildAll = true; };
- hikari = super.hikari.overrideAttrs (old: {
- makeFlags = old.makeFlags ++ [ "DEBUG=YES" ];
- patches = [ ./patches/hikari-gtk4.patch ];
- });
-
akkoma-fe = super.akkoma-frontends.akkoma-fe.overrideAttrs (old: {
patches = [ ./patches/akkoma-fe-toki-pona.patch ];
});
@@ -209,6 +204,18 @@ in
[ "PREFIX=$(out)" "WITH_POSIX_C_SOURCE=YES"
"WITH_GAMMACONTROL=YES" "WITH_LAYERSHELL=YES" "WITH_SCREENCOPY=YES" ];
})).override { wlroots = unstable.wlroots_0_16; stdenv = self.clangStdenv; };
+ hikari = self.callPackage ./hikari.nix { wlroots = self.wlroots_0_15; };
+
+ wlroots_0_15 = (self.wlroots_0_16.overrideAttrs rec {
+ version = "0.15.1";
+ src = self.fetchFromGitLab {
+ domain = "gitlab.freedesktop.org";
+ owner = "wlroots";
+ repo = "wlroots";
+ rev = version;
+ hash = "sha256-MFR38UuB/wW7J9ODDUOfgTzKLse0SSMIRYTpEaEdRwM=";
+ };
+ });
travelynx = self.callPackage ./travelynx.nix {};