summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
authorstuebinm2023-11-14 21:43:06 +0100
committerstuebinm2023-11-15 01:39:36 +0100
commitb9f2405fdf68a9d04359f8efafb544df11528668 (patch)
tree5e7e5968bd0f72cc18e8212f0cb50c99439df5e3 /pkgs/overlay.nix
parent579dc4f19e4c4b36a927d93425b1f778a8ab4c86 (diff)
bahnhof.name haskell rewrite
Diffstat (limited to 'pkgs/overlay.nix')
-rw-r--r--pkgs/overlay.nix42
1 files changed, 31 insertions, 11 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 7449786..71ee3b4 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -84,17 +84,37 @@ in
isabelle-rust-utils = self.isabelle-utils;
};
- bahnhof-name = let
- inherit (self.callPackage "${inputs.nix-gleam.outPath}/builder/default.nix" {}) buildGleamApplication;
- in buildGleamApplication {
- version = "0.1";
- pname = "bahnhof.name";
- src = inputs.bahnhof-name;
-
- postInstall = ''
- cp -r $src/data $out
- '';
- };
+ bahnhof-name =
+ let
+ haskellPkgs = self.haskellPackages.override (old: {
+ overrides = self': super': with self.haskell.lib; {
+ fuzzyfind = unmarkBroken (doJailbreak super'.fuzzyfind);
+ };
+ });
+ pkg = { mkDerivation, base, bytestring, cassava, containers
+ , fuzzyfind, fuzzyset, http-client, http-client-openssl, http-types
+ , lib, stm, text, time, vector, wai, wai-extra, warp
+ }:
+ mkDerivation {
+ pname = "bahnhof.name";
+ version = "0.2.0.0";
+ src = inputs.bahnhof-name;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ base bytestring cassava containers fuzzyfind fuzzyset http-client
+ http-client-openssl http-types stm text time vector wai wai-extra
+ warp
+ ];
+ mainProgram = "bahnhof-name";
+ license = lib.licenses.eupl12;
+ postInstall = ''
+ cp -r $src/data $out
+ '';
+ };
+ in
+ haskellPkgs.callPackage pkg {};
+
#### sporadically maintained / updated ####