summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
authorstuebinm2024-04-28 21:30:47 +0200
committerstuebinm2024-04-29 00:02:55 +0200
commit9e7a775e2578e126dddb1c6f7514874265e3d08e (patch)
tree68a72299d6c5ca706ee357fdbc73d8dd4ceef010 /pkgs/overlay.nix
parent806593f53dde83f367fd9f6ee74a21aef97faf44 (diff)
yeet the nix flakes
this is, in the widest possible sense, a revert of e88fed18f499a3e8ac98c772bbb62f00d1f8d1d7, which was now a little over two years ago. Of course, lots of things have changed since then: - this uses npins instead of niv, which is both simpler and still maintained - i haven't brought back the old deploy lib; I still use deploy-rs (with some modifications) to deploy things - if you actually use my stuff downstream, you can now use packages/ & tests/ & modules/ as entry points directly, while still having some control over inputs - (since i also don't believe any downstream users actually exist, i've not bothered to have a shim flake.nix so your stuff probably just broke. well, it was an experimental feature, anyways) - in general there's a lot more of the old-fashioned structure back again, with default.nix files in subdirectories that form a structure, not like how almost everything was just imported in the one big flake.nix file For people who are interested in also having a non-flake config similar to this one, it's probably best to take a look at inputs.nix (and also at npins, of course)
Diffstat (limited to 'pkgs/overlay.nix')
-rw-r--r--pkgs/overlay.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 4d1d55d..f7e4c5f 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -1,8 +1,9 @@
-{ inputs, ... }:
+{ inputs ? import ../inputs.nix }:
+
self: super:
let
- unstable = inputs.nixpkgs-unstable.legacyPackages.${self.system};
+ unstable = inputs.nixpkgs-unstable;
crs-tools = self.callPackage ./crs-tools.nix {};
rustPlatform = self.makeRustPlatform {
cargo = self.rust-bin.stable.latest.minimal;
@@ -55,7 +56,7 @@ in
almanac = self.rustPlatform.buildRustPackage rec {
pname = "almanac";
version = "git";
- src = inputs.almanac.outPath;
+ src = inputs.almanac;
cargoLock.lockFile = "${src}/Cargo.lock";
};