summaryrefslogtreecommitdiff
path: root/pkgs/matrix-to.nix
diff options
context:
space:
mode:
authorstuebinm2023-07-28 13:57:53 +0200
committerstuebinm2023-07-28 14:06:26 +0200
commit2c18fa585efada5e91a0cb8b6988ff15154c8be1 (patch)
tree2afc8edb775f602be5d1bd3dbf20bcd91e9a4058 /pkgs/matrix-to.nix
parent542a28a38a2adf2307e9b803de9cb62a67af75c6 (diff)
package matrix.to
apparently the default homeserver this uses is not configurable??? … might hack around later
Diffstat (limited to 'pkgs/matrix-to.nix')
-rw-r--r--pkgs/matrix-to.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/matrix-to.nix b/pkgs/matrix-to.nix
new file mode 100644
index 0000000..7e9fe25
--- /dev/null
+++ b/pkgs/matrix-to.nix
@@ -0,0 +1,29 @@
+{ mkYarnPackage, fetchYarnDeps, fetchFromGitHub, lib }:
+
+mkYarnPackage rec {
+ pname = "matrix.to";
+ version = "1.2.16";
+
+ src = fetchFromGitHub {
+ owner = "matrix-org";
+ repo = "matrix.to";
+ rev = version;
+ sha256 = "sha256-NeEtRFAjvbW8K5ysm0wMYc1MushF9YT1Nvhucd2fIyE=";
+ };
+
+ offlineCache = fetchYarnDeps {
+ yarnLock = "${src.outPath}/yarn.lock";
+ hash = "sha256-KFNU6V9JVa3+O9HOGtHfEGj7nq9TizLiNOiWROCPUHQ=";
+ };
+
+ buildPhase = ''
+ yarn --offline build
+ '';
+
+ distPhase = "true";
+
+ installPhase = ''
+ mkdir -p $out
+ cp -r deps/matrix.to/build/* $out
+ '';
+}