summaryrefslogtreecommitdiff
path: root/inputs.nix
diff options
context:
space:
mode:
authorstuebinm2024-06-04 21:14:49 +0200
committerstuebinm2024-06-04 21:14:49 +0200
commitd27e67743931d352e5857b605d44657668fa9013 (patch)
treebad8f97e5f47e791f7f6a3e0b94ef45b5ff0e131 /inputs.nix
parent9bf026e55b72af7aa14096440537fefddc56c212 (diff)
all: jump to nixpkgs 24.05
this does a lot of things, most of which are maintenance: - sources update - adjust newly-renamed options - swap some packages that were removed / renamed - update nomsring to newer default ghc - remove the deprecated lib.mdDoc from modules/*.nix - disable the nixpkgs mollysocket module so my own keeps evaluating - bundle the package definition of hikari & wlroots 0.15, which nixpkgs has removed as unmaintained (in fairness, they are unmaintained)
Diffstat (limited to 'inputs.nix')
-rw-r--r--inputs.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/inputs.nix b/inputs.nix
index 0d2851c..8902303 100644
--- a/inputs.nix
+++ b/inputs.nix
@@ -7,7 +7,7 @@ let
callFlake = name: inputs:
let
self = (import "${sources.${name}}/flake.nix").outputs
- ({ inherit self; } // inputs);
+ ({ self = self // { outPath = sources.${name}.outPath; }; } // inputs);
in
self // { outPath = sources.${name}.outPath; };
@@ -41,7 +41,8 @@ let
# this absurd third copy only exists because non-flake nixpkgs does not
# as easily expose the evalConfig function ..
nixpkgs-flake =
- (import "${sources.nixpkgs}/flake.nix").outputs { self = nixpkgs-flake; };
+ (import "${sources.nixpkgs}/flake.nix").outputs { self = nixpkgs-flake; }
+ // { outPath = sources.nixpkgs.outPath; };
home-manager = callFlake "home-manager" { inherit nixpkgs; };