summaryrefslogtreecommitdiff
path: root/ilex/hardware-configuration.nix
diff options
context:
space:
mode:
authorstuebinm2023-01-08 02:00:21 +0100
committerstuebinm2023-01-08 02:00:21 +0100
commit709e787915998ab74d8bc1280e6bcee989ec48b8 (patch)
tree01a57683eb0f673c4ebabe977074d359e4877827 /ilex/hardware-configuration.nix
parenta4fda580f377928a0e84b40bc80bafa1d876fc7c (diff)
init ilex
Diffstat (limited to 'ilex/hardware-configuration.nix')
-rw-r--r--ilex/hardware-configuration.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/ilex/hardware-configuration.nix b/ilex/hardware-configuration.nix
new file mode 100644
index 0000000..1170585
--- /dev/null
+++ b/ilex/hardware-configuration.nix
@@ -0,0 +1,38 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/7f142287-459f-494b-8b84-4fa4f415cf5a";
+ fsType = "ext4";
+ };
+
+ boot.initrd.luks.devices."cryptroot".device = "/dev/disk/by-uuid/d569d5d9-bd3a-4a4f-9b92-0e639a064a29";
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/4FD9-0A28";
+ fsType = "vfat";
+ };
+
+ swapDevices = [ ];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp1s0f0.useDHCP = lib.mkDefault true;
+
+ hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}