summaryrefslogtreecommitdiff
path: root/ilex/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2023-04-01 02:54:35 +0200
committerstuebinm2023-04-01 02:54:35 +0200
commitf4f3f7d0ad49cfb9d73061997523f69c31716739 (patch)
tree25fb76ce0d043e59100c46860425791aedbcd3ef /ilex/configuration.nix
parent15c29107417f4c82e534c757a69d36101c506a2a (diff)
add module for crs-tracker, for fun
please no one like, actually use this. unless you volunteer to at least add a script to run database migrations, since currently these need to be run by hand …
Diffstat (limited to 'ilex/configuration.nix')
-rw-r--r--ilex/configuration.nix33
1 files changed, 25 insertions, 8 deletions
diff --git a/ilex/configuration.nix b/ilex/configuration.nix
index 462cc3f..9b7f5fb 100644
--- a/ilex/configuration.nix
+++ b/ilex/configuration.nix
@@ -8,6 +8,7 @@
imports = [
./hardware-configuration.nix
../modules/glitchtip.nix
+ ../modules/crs-tools.nix
];
networking.firewall.allowedTCPPorts = [ 5000 ];
@@ -34,7 +35,7 @@
services.postgresql = {
enable = true;
- ensureDatabases = [ "tracktrain" "glitchtrip" ];
+ ensureDatabases = [ "tracktrain" "glitchtrip" "crstracker" ];
ensureUsers = [ {
name = "tracktrain";
ensurePermissions = {
@@ -45,25 +46,41 @@
ensurePermissions = {
"DATABASE glitchtrip" = "ALL PRIVILEGES";
};
+ } {
+ name = "crstracker";
+ ensurePermissions = {
+ "DATABASE crstracker" = "ALL PRIVILEGES";
+ };
} ];
authentication = ''
local all all trust
host all all 127.0.0.1/32 trust
host all all ::1/127 trust
'';
+ package = pkgs.postgresql_11;
};
- services.glitchtip = {
- enable = true;
- databaseUrl = "postgres://glitchtrip@localhost:5432/glitchtrip";
- };
- services.redis.servers.glitchtip = {
+ # services.glitchtip = {
+ # enable = true;
+ # databaseUrl = "postgres://glitchtrip@localhost:5432/glitchtrip";
+ # };
+ # services.redis.servers.glitchtip = {
+ # enable = true;
+ # port = 6379;
+ # };
+
+ services.crs-tracker = {
enable = true;
- port = 6379;
+ nginxVirtualHostConfig = {
+ listen = [{
+ addr = "127.0.0.1";
+ port = 8080;
+ ssl = false;
+ }];
+ };
};
-
services.tlp = {
enable = true;
settings = {