summaryrefslogtreecommitdiff
path: root/ilex/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2023-01-08 02:00:21 +0100
committerstuebinm2023-01-08 02:00:21 +0100
commit709e787915998ab74d8bc1280e6bcee989ec48b8 (patch)
tree01a57683eb0f673c4ebabe977074d359e4877827 /ilex/configuration.nix
parenta4fda580f377928a0e84b40bc80bafa1d876fc7c (diff)
init ilex
Diffstat (limited to 'ilex/configuration.nix')
-rw-r--r--ilex/configuration.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/ilex/configuration.nix b/ilex/configuration.nix
new file mode 100644
index 0000000..a778d21
--- /dev/null
+++ b/ilex/configuration.nix
@@ -0,0 +1,33 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./hardware-configuration.nix
+ ];
+
+ # Use the systemd-boot EFI boot loader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.hostName = "ilex";
+ time.timeZone = "Europe/Amsterdam";
+
+ services.openssh.enable = true;
+ services.openssh.permitRootLogin = "yes";
+
+ networking = {
+ networkmanager.enable = true;
+ useDHCP = false;
+ interfaces = {
+ enp1s0f0.useDHCP = true;
+ };
+ };
+
+ system.stateVersion = "22.11";
+
+}
+