summaryrefslogtreecommitdiff
path: root/ilex/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2023-03-22 03:15:41 +0100
committerstuebinm2023-03-22 03:15:41 +0100
commit50f74d35e73529e67a27cee7fcd36e18a6d92e3a (patch)
tree24156224569cc55bef590cab002d4ca1f3c223fc /ilex/configuration.nix
parent9b017a8ef302fe0317718a30af80bf2d51e07009 (diff)
package glitchtip
i don't know why i did this. i literally have no use for it.
Diffstat (limited to 'ilex/configuration.nix')
-rw-r--r--ilex/configuration.nix24
1 files changed, 23 insertions, 1 deletions
diff --git a/ilex/configuration.nix b/ilex/configuration.nix
index 6599cd4..2b07092 100644
--- a/ilex/configuration.nix
+++ b/ilex/configuration.nix
@@ -33,19 +33,41 @@
services.postgresql = {
enable = true;
- ensureDatabases = [ "tracktrain" ];
+ ensureDatabases = [ "tracktrain" "glitchtrip" ];
ensureUsers = [ {
name = "tracktrain";
ensurePermissions = {
"DATABASE tracktrain" = "ALL PRIVILEGES";
};
+ } {
+ name = "glitchtrip";
+ ensurePermissions = {
+ "DATABASE glitchtrip" = "ALL PRIVILEGES";
+ };
} ];
authentication = ''
local all all trust
host all all 127.0.0.1/32 trust
+ host all all ::1/127 trust
'';
};
+ services.uwsgi = {
+ enable = true;
+ plugins = [ "python3" ];
+ instance = {
+ type = "normal";
+ pythonPackages = self: [ pkgs.glitchtip ];
+ module = "glitchtip.wsgi:application";
+ chdir = pkgs.glitchtip;
+ http = ":8080";
+ env = [
+ "DATABASE_URL=postgres://glitchtrip@localhost:5432/glitchtrip"
+ ];
+ };
+ };
+
+
services.tlp = {
enable = true;
settings = {