summaryrefslogtreecommitdiff
path: root/hosts/flora/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-08 00:22:48 +0100
committerstuebinm2021-03-08 00:22:48 +0100
commit6b79492de7467e44733d2644273185af548dc20b (patch)
treee8b7c217dd30aba20fbebac44b71dcbfd7eb1482 /hosts/flora/configuration.nix
parentd96fbd63510048bf56d3d600a65f7983096c1bb1 (diff)
Added Pleroma
This pleroma config should be able to set itself up without any manual intervention (modulo the secrets file, which is almost empty). Annoyingly, the pleroma nixpkg is built from the pipeline artifacts of the pleroma gitlab and does not have support for pleroma's ssh/bbs mode.
Diffstat (limited to 'hosts/flora/configuration.nix')
-rw-r--r--hosts/flora/configuration.nix23
1 files changed, 13 insertions, 10 deletions
diff --git a/hosts/flora/configuration.nix b/hosts/flora/configuration.nix
index 43f7f8e..0d1788d 100644
--- a/hosts/flora/configuration.nix
+++ b/hosts/flora/configuration.nix
@@ -7,7 +7,8 @@
./services/daemoniones.nix
./services/nginx.nix
./services/workadventure.nix
- # ./services/pleroma
+ #./../../../nginx/vod.nix
+ ./services/pleroma.nix
];
# Use the GRUB 2 boot loader.
@@ -22,21 +23,23 @@
networking = {
hostName = "flora";
- #enableIPv6 = true;
- #defaultGateway6 = {
- # address = "fe80::1";
- # interface = "ens3";
- #};
+ enableIPv6 = true;
+ defaultGateway6 = {
+ address = "fe80::1";
+ interface = "ens3";
+ };
- #interfaces.ens3.ipv6.addresses = [ {
- # address = "2a01:4f9:c010:d319::1";
- # prefixLength = 64;
- #} ];
+ interfaces.ens3.ipv6.addresses = [ {
+ address = "2a01:4f9:c010:df15::1";
+ prefixLength = 64;
+ } ];
useDHCP = false;
interfaces.ens3.useDHCP = true;
firewall.logRefusedConnections = false;
+
+
};
services.fail2ban = {