summaryrefslogtreecommitdiff
path: root/hosts/abbenay/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-10 00:42:01 +0100
committerstuebinm2022-01-10 01:56:35 +0100
commit38ba8be512b8dbb8838fbca9865b2a8d24f6bee1 (patch)
tree87d7c07a54627b781531cda677d90c0fffdac077 /hosts/abbenay/configuration.nix
parentbe4ac10c641e39babc83db479c827b6dfb0af103 (diff)
add abbenay (desktop config)
Diffstat (limited to 'hosts/abbenay/configuration.nix')
-rw-r--r--hosts/abbenay/configuration.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/hosts/abbenay/configuration.nix b/hosts/abbenay/configuration.nix
new file mode 100644
index 0000000..2aabaa7
--- /dev/null
+++ b/hosts/abbenay/configuration.nix
@@ -0,0 +1,58 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./hardware-configuration.nix
+ ];
+
+ services.flatpak.enable = true;
+ services.avahi.enable = true;
+ services.avahi.nssmdns = true;
+
+ services.xserver = {
+ displayManager.gdm.enable = true;
+ desktopManager.gnome.enable = true;
+ };
+ services.gnome.gnome-keyring.enable = pkgs.lib.mkForce false;
+
+ environment.systemPackages = with pkgs; [
+ gnome3.gnome-tweaks
+ flatpak flatpak-builder
+ # for mounting samba
+ cifs-utils
+ ];
+
+ networking = {
+ hostName = "matthias-nix";
+
+ useDHCP = false;
+ interfaces.enp3s0.useDHCP = true;
+ # networkmanager shouldn't handle nixos container
+ networkmanager.unmanaged = [ "interface-name:ve-*" ];
+ };
+ # nixos containers should have internet access
+ networking.nat = {
+ enable = true;
+ internalInterfaces = ["ve-+"];
+ externalInterface = "eth0";
+ };
+
+ boot = {
+ extraModulePackages = with config.boot.kernelPackages; [ v4l2loopback ];
+ kernelModules = [ "v4l2loopback" ];
+ };
+
+ # Use the systemd-boot EFI boot loader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+ boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "20.03"; # Did you read the comment?
+
+}