summaryrefslogtreecommitdiff
path: root/home/packages.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-17 00:19:59 +0100
committerstuebinm2022-01-20 13:16:43 +0100
commit71a9f3858e42856ef81ad92553a7732811186733 (patch)
treec2fa2ba37bda94491a36fd2e0dffd37d443f7ccb /home/packages.nix
parentc48f90064724ce1d802038524f60cce7baf53e69 (diff)
attempting home-manager config with flakes
Diffstat (limited to 'home/packages.nix')
-rw-r--r--home/packages.nix69
1 files changed, 69 insertions, 0 deletions
diff --git a/home/packages.nix b/home/packages.nix
new file mode 100644
index 0000000..55036d8
--- /dev/null
+++ b/home/packages.nix
@@ -0,0 +1,69 @@
+{ config, lib, pkgs, inputs, ... }:
+
+let
+ naersk = pkgs.callPackage inputs.naersk {};
+ extras = {
+ sfz = naersk.buildPackage inputs.sfz;
+ };
+in
+{
+ home.packages = with pkgs; [
+ (emacsWithPackages (epkgs: [ epkgs.exwm epkgs.pdf-tools epkgs.vterm ]))
+ emacs-all-the-icons-fonts
+
+ # flake-enabled version of nix
+ (pkgs.writeScriptBin "nif" ''
+ #!/usr/bin/env bash
+ exec ${pkgs.nixFlakes}/bin/nix --experimental-features "nix-command flakes" "$@"
+ '')
+ # never version of unison for playing around
+ (unison-ucm.overrideAttrs (old: rec {
+ milestone_id = "M2g";
+ version = "1.0.${milestone_id}-alpha";
+ src = fetchurl {
+ url = "https://github.com/unisonweb/unison/releases/download/release/${milestone_id}/ucm-linux.tar.gz";
+ sha256 = "004jx7q657mkcrvilk4lfkp8xcpl2bjflpn9m2p7jzlrlk97v9nj";
+ };
+ }))
+ # internet apps & clients
+ firefox thunderbird keepassxc chromium signal-desktop mumble lynx
+ openconnect matterhorn
+ # graphics & audio
+ audacity blender darktable vlc kdenlive moc ffmpeg-full
+ gimp-with-plugins inkscape krita meshlab pavucontrol moc
+ gst_all_1.gstreamer
+ # LaTeX & documents
+ texlive.combined.scheme-full xournal pandoc
+ # extra documentation, data, resources that aren't programs
+ manpages nerdfonts
+ # general cli utils
+ tree dnsutils inetutils pijul bat age libsecret gping bottom dogdns
+ cifs-utils jekyll fzf ripgrep fd bandwhich exa dive
+ ripgrep python39Packages.isort shellcheck graphviz
+ poppler unzip acpi extras.sfz
+ youtube-dl
+ # git
+ gitAndTools.gitAnnex git-bug git-appraise
+ # graphical utils
+ kitty baobab
+ # things for emacs
+ sqlite brightnessctl scrot playerctl tlp
+ # haskell & co
+ ghc cabal-install stack haskell.packages.ghc8107.haskell-language-server
+ haskellPackages.hoogle haskellPackages.stylish-haskell
+ # other functional things
+ racket dhall lean dune_2 ocamlPackages.utop ocamlPackages.ocp-indent
+ ocamlPackages.merlin ocaml
+ # html, js & co
+ jq html-tidy nodePackages.stylelint nodePackages.js-beautify zola
+ # purescript
+ spago purescript # nodePackages.purescript-language-server nodejs
+ # rust
+ rls cargo rustc rust-analyzer rustfmt
+ # others
+ gcc nixfmt niv cachix julia_16-bin python39
+ # isabelle
+ # (import "${inputs.playground.outPath}/isabelle-nix-fhsenv")
+ # (import /home/stuebinm/projects/isabelle-utils {}).isabat
+ ];
+}