summaryrefslogtreecommitdiff
path: root/home/packages.nix
diff options
context:
space:
mode:
authorstuebinm2024-02-11 18:22:53 +0100
committerstuebinm2024-02-11 18:22:53 +0100
commit2d130f50f30643ffbf1090b4db8e97b530b86f69 (patch)
treedf901ebf6c63737c84688683da8779916d5e7cc2 /home/packages.nix
parenteade932667731845341309e43c721d7a49ab6e38 (diff)
home: add twelf
for Chris Marten's logic course. Uses an unofficial version from github since the actually released version is so old that the elisp code for the emacs mode doesn't work with an up-to-date emacs anymore.
Diffstat (limited to 'home/packages.nix')
-rw-r--r--home/packages.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/home/packages.nix b/home/packages.nix
index 10c65ec..ce4fc4e 100644
--- a/home/packages.nix
+++ b/home/packages.nix
@@ -43,6 +43,14 @@ in
racket dhall lean4 dune_2 ocamlPackages.utop ocamlPackages.ocp-indent
ocamlPackages.merlin ocaml gauche
(agda.withPackages (p: [ p.standard-library p.cubical ]))
+ (twelf.overrideAttrs (old: {
+ src = fetchFromGitHub {
+ owner = "k4rtik";
+ repo = "twelf";
+ rev = "c1bec0d0b9fa506e36bb364b1765191b159e6c4c";
+ hash = "sha256-sh/yMlCvMMq6GBqAKO+V0Bcyp38zB7I/3H8a0fxqOos=";
+ };
+ }))
# html, js & co
jq html-tidy nodePackages.stylelint nodePackages.js-beautify zola
libxml2 fq htmlq