summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorstuebinm2022-11-25 23:31:00 +0100
committerstuebinm2022-11-25 23:31:13 +0100
commit23b7f37448f7681f9b71098f626e65776dbe716e (patch)
tree1fb7e7eeec14078c94eb26c2a0a311c4bdf345e7 /flake.nix
parent38e3b2e9056f95cb82c39efaa45fdf14730d41ba (diff)
add home manager deployment for parsons (hacc server)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index e7ee9a1..ac631a0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -73,6 +73,14 @@
deploy.nodes = {
chaski = deploy-vps "chaski";
flora = deploy-vps "flora";
+ parsons = {
+ hostname = "parsons";
+ profiles.home = {
+ user = "stuebinm";
+ sshUser = "stuebinm";
+ path = deploy-rs.lib.x86_64-linux.activate.home-manager self.homeConfigurations.stuebinm-minimal;
+ };
+ };
};
checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib;