summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorstuebinm2023-02-16 19:36:01 +0100
committerstuebinm2023-02-16 19:36:01 +0100
commit02c7dc192e9bc9a1246edc48ec23271ea07abd45 (patch)
tree220dbabedaf78031b433206d93c5578aa34b693d /flake.nix
parent86cf1da3d2444a984fec0e34c66aac8139207f06 (diff)
flora: jump to akkoma @ nixpkgs-unstable
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index f88ead0..9d6d552 100644
--- a/flake.nix
+++ b/flake.nix
@@ -48,11 +48,11 @@
outputs = { self, nixpkgs, deploy-rs, ... }@inputs:
let
mkConfig = imports: config:
- nixpkgs.lib.nixosSystem {
+ nixpkgs.lib.nixosSystem rec {
system = "x86_64-linux";
modules = [ config ] ++ imports;
- specialArgs = { inherit inputs; };
+ specialArgs = { inherit inputs system; };
};
mkServer = mkConfig [ ./common/headless.nix ];
mkDesktop = mkConfig [ ./common/desktop.nix ];