summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-03 00:51:39 +0100
committerstuebinm2021-03-03 00:51:39 +0100
commitd96fbd63510048bf56d3d600a65f7983096c1bb1 (patch)
tree192afecb97bcdb829e1461bebc283cc86fb99586 /default.nix
migrating config
This deploy logic is primarily based on hxchn's deploy lib [1], with some slight modifications to make it work with my setup. Everything seems to work fine for now. However, I am unsure about the usage of niv — the config doesn't seem to gain much from it, apart from (some) additional complexity. [1] https://gitlab.com/hexchen/nixfiles
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..f13eb77
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,18 @@
+let
+ sources = import ./nix/sources.nix;
+ pkgs = import ./pkgs {};
+
+ hosts = import ./lib/hosts.nix {
+ inherit pkgs;
+ hostsDir = ./hosts;
+ commonImports = [ ./common ];
+ pkgsPath = ./pkgs;
+ };
+in
+{
+ inherit sources pkgs;
+ inherit (hosts) hosts groups;
+ deploy = import ./lib/deploy.nix { inherit pkgs; inherit (hosts) hosts groups; };
+}
+
+