summaryrefslogtreecommitdiff
path: root/cyberbox/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-18 09:43:24 +0100
committerstuebinm2022-01-20 13:19:44 +0100
commit0bcabe1c4b1dd74af233674dfa6c6ec3011ce2c0 (patch)
tree5c58943f99245ff7f745f50b46c34ae288c3e503 /cyberbox/configuration.nix
parentdb83a406bc6e63289e47ff5d2228c08430832655 (diff)
restructuring directories
Diffstat (limited to 'cyberbox/configuration.nix')
-rw-r--r--cyberbox/configuration.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/cyberbox/configuration.nix b/cyberbox/configuration.nix
new file mode 100644
index 0000000..47ffaad
--- /dev/null
+++ b/cyberbox/configuration.nix
@@ -0,0 +1,59 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./hardware-configuration.nix
+ ];
+
+ # laptop power things
+ services.tlp.enable = true;
+
+ programs.light.enable = true;
+ programs.slock.enable = true;
+
+
+ # Use the GRUB 2 boot loader.
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
+
+ networking = {
+ hostName = "cyberbox"; # Define your hostname.
+ networkmanager.enable = true;
+ useDHCP = false;
+ interfaces.enp0s25.useDHCP = true;
+ interfaces.wlp3s0.useDHCP = true;
+ };
+
+
+ # Enable the X11 windowing system.
+ services.xserver.enable = true;
+
+ # entrypoint for emacs configured with home-manager
+ # (must be available on the user's $PATH)
+ services.xserver.windowManager.session = pkgs.lib.singleton {
+ name = "exwm";
+ start = "emacs -l ${pkgs.writeText "emacs-exwm-load" ''
+ (require 'exwm-config)
+ (exwm-config-default)
+ (defvar inexwm t)
+ ''}";
+ };
+
+ # Enable sound.
+ sound.enable = true;
+ hardware.pulseaudio.enable = true;
+
+ # Enable touchpad support (enabled default in most desktopManager).
+ services.xserver.libinput.enable = true;
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "20.09"; # Did you read the comment?
+
+}
+