summaryrefslogtreecommitdiff
path: root/common/desktop.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-26 17:43:17 +0100
committerstuebinm2022-01-26 17:43:17 +0100
commit4c834deb2feab291d599231c0a9edb27937889c6 (patch)
treeb7c5fd500c9cd9374bb4ba0142a4b4089d151619 /common/desktop.nix
parent21e93e9cfda16382ba2ee56257be425cc54d3264 (diff)
move abbenay to hikari as well
Diffstat (limited to 'common/desktop.nix')
-rw-r--r--common/desktop.nix47
1 files changed, 30 insertions, 17 deletions
diff --git a/common/desktop.nix b/common/desktop.nix
index f7d6b8f..8bc1968 100644
--- a/common/desktop.nix
+++ b/common/desktop.nix
@@ -14,28 +14,12 @@
virtualisation.podman.enable = true;
- # Select internationalisation properties.
- console = {
- font = "Lat2-Terminus16";
- keyMap = "de";
- };
-
# Enable CUPS to print documents.
services.printing = {
enable = true;
drivers = [ pkgs.epson-escpr2 pkgs.epson-escpr ];
};
-
- # Enable sound.
- sound.enable = true;
- hardware.pulseaudio.enable = true;
-
- # Enable the X11 windowing system.
- # services.xserver.enable = true;
- # services.xserver.layout = "de";
- # services.xserver.xkbOptions = "eurosign:e,caps:escape";
-
users.mutableUsers = false;
users.defaultUserShell = pkgs.fish;
users.users.stuebinm = {
@@ -46,7 +30,6 @@
useDefaultShell = true;
};
-
services.syncthing = {
enable = true;
user = "stuebinm";
@@ -59,4 +42,34 @@
"127.0.0.1" = [ "syncthing.localhost" ];
};
+ # graphics and stuff
+ programs.light.enable = true;
+ programs.slock.enable = true;
+
+ environment.systemPackages = with pkgs; [
+ hikari fuzzel
+ ];
+
+ security.pam.services.hikari-unlocker.text = ''
+ auth include login
+ '';
+
+ services.greetd = {
+ enable = true;
+ settings.default_session = {
+ command = "${pkgs.greetd.greetd}/bin/agreety --cmd 'hikari -c ~/hikari.conf'";
+ user = "stuebinm";
+ };
+ restart = false;
+ };
+ hardware.opengl.enable = true;
+ fonts.enableDefaultFonts = true;
+ programs.xwayland.enable = false;
+ xdg.portal.extraPortals = [ pkgs.xdg-desktop-portal-wlr ];
+ xdg.portal.enable = true;
+ services.flatpak.enable = true;
+
+ # Enable sound.
+ sound.enable = true;
+ hardware.pulseaudio.enable = true;
}