summaryrefslogtreecommitdiff
path: root/common/cachix.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-10 00:42:01 +0100
committerstuebinm2022-01-10 01:56:35 +0100
commit38ba8be512b8dbb8838fbca9865b2a8d24f6bee1 (patch)
tree87d7c07a54627b781531cda677d90c0fffdac077 /common/cachix.nix
parentbe4ac10c641e39babc83db479c827b6dfb0af103 (diff)
add abbenay (desktop config)
Diffstat (limited to 'common/cachix.nix')
-rw-r--r--common/cachix.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/common/cachix.nix b/common/cachix.nix
new file mode 100644
index 0000000..88b2f08
--- /dev/null
+++ b/common/cachix.nix
@@ -0,0 +1,13 @@
+
+# WARN: this file will get overwritten by $ cachix use <name>
+{ pkgs, lib, ... }:
+
+let
+ folder = ./cachix;
+ toImport = name: value: folder + ("/" + name);
+ filterCaches = key: value: value == "regular" && lib.hasSuffix ".nix" key;
+ imports = lib.mapAttrsToList toImport (lib.filterAttrs filterCaches (builtins.readDir folder));
+in {
+ inherit imports;
+ nix.binaryCaches = ["https://cache.nixos.org/"];
+}