summaryrefslogtreecommitdiff
path: root/chaski/services/woitb.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-18 09:43:24 +0100
committerstuebinm2022-01-20 13:19:44 +0100
commit0bcabe1c4b1dd74af233674dfa6c6ec3011ce2c0 (patch)
tree5c58943f99245ff7f745f50b46c34ae288c3e503 /chaski/services/woitb.nix
parentdb83a406bc6e63289e47ff5d2228c08430832655 (diff)
restructuring directories
Diffstat (limited to 'chaski/services/woitb.nix')
-rw-r--r--chaski/services/woitb.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/chaski/services/woitb.nix b/chaski/services/woitb.nix
new file mode 100644
index 0000000..0c50617
--- /dev/null
+++ b/chaski/services/woitb.nix
@@ -0,0 +1,32 @@
+{ config, lib, pkgs, inputs, ... }:
+
+let
+ #sources = ../../nix/sources.nix;
+ sources = /home/stuebinm/Dokumente/utils/playground/ilztal/server;
+in
+{
+ # systemd.services.woitb = {
+ # enable = true;
+ # description = "wo ist die ilztalbahn?";
+ # wantedBy = [ "multi-user.target" ];
+ # serviceConfig.type = "simple";
+ # script = "${import sources}/bin/woitb";
+ # };
+
+ services.nginx.enable = true;
+ services.nginx.virtualHosts."ilztal.live" = {
+ enableACME = true;
+ forceSSL = true;
+ locations."/".root = pkgs.copyPathToStore ./woitb;
+
+ # locations."/upnext".proxyPass = "http://localhost:8000";
+ # locations."/geoloc".proxyPass = "http://localhost:8000";
+ };
+
+ services.nginx.virtualHosts."track.ilztal.live" = {
+ enableACME = true;
+ forceSSL = true;
+ locations."/".root = inputs.tracktrain;
+ };
+
+}