summaryrefslogtreecommitdiff
path: root/abbenay/hpc.nix
diff options
context:
space:
mode:
authorstuebinm2022-11-06 17:51:29 +0100
committerstuebinm2022-11-11 21:20:58 +0100
commite598b080e616ab2d388ddd983c0957bb19d6e0a1 (patch)
tree1a248126c8be7de590b32653aaf575384f03c5ff /abbenay/hpc.nix
parent421f58aa8b7c3b3f1cd1e9ddfe9f7081782e9011 (diff)
add nfs for slurm
Diffstat (limited to 'abbenay/hpc.nix')
-rw-r--r--abbenay/hpc.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/abbenay/hpc.nix b/abbenay/hpc.nix
index 2bbd2d5..469acb5 100644
--- a/abbenay/hpc.nix
+++ b/abbenay/hpc.nix
@@ -6,6 +6,7 @@
password = "/tmp/munge/key";
};
+
services.slurm = {
server.enable = true;
client.enable = true;
@@ -47,8 +48,8 @@
SlurmdLogFile=/var/log/slurmd.log
# COMPUTE NODES
- NodeName=abbenay CPUs=2 State=UNKNOWN
- # NodeName=cyberbox CPUs=1 State=UNKNOWN
+ NodeName=abbenay CPUs=4 State=UNKNOWN
+ NodeName=cyberbox CPUs=1 State=UNKNOWN
# [add more nodes here]
PartitionName=debug Nodes=ALL Default=YES MaxTime=INFINITE State=UP
'';
@@ -63,7 +64,7 @@
};
};
- networking.firewall.allowedTCPPorts = [ 6817 6818 ];
+ networking.firewall.allowedTCPPorts = [ 6817 6818 6819 ];
networking.firewall.allowedTCPPortRanges = [ {
from = 60001;
to = 63000;
@@ -73,4 +74,13 @@
enable = true;
package = pkgs.mariadb;
};
+
+ networking.hosts."192.168.69.104" = [ "cyberbox" ];
+ networking.firewall.enable = false;
+
+
+ environment.systemPackages = with pkgs; [
+cmake lapack blas netcdf netcdffortran perl libxml2 pkg-config perl534Packages.XMLLibXML tcsh subversion
+openmpi
+ ];
}