summaryrefslogtreecommitdiff
path: root/abbenay/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2024-03-10 23:24:31 +0100
committerstuebinm2024-03-10 23:24:31 +0100
commit1af7f4da6145aa2e2a7695f86349fe5cc61d855b (patch)
tree0347b430328cf9621226915a110e93c8991982a2 /abbenay/configuration.nix
parentca98c4ba1a012feff05e2583e44f7ab93b937e7a (diff)
abbenay: run a hydra instance for fun
Diffstat (limited to 'abbenay/configuration.nix')
-rw-r--r--abbenay/configuration.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/abbenay/configuration.nix b/abbenay/configuration.nix
index 62a4a58..99f8a97 100644
--- a/abbenay/configuration.nix
+++ b/abbenay/configuration.nix
@@ -3,14 +3,18 @@
{
imports = [
./hardware-configuration.nix
- ./hpc.nix
+ ./hydra.nix
];
services.avahi.enable = true;
services.avahi.nssmdns = true;
+ services.openssh.enable = true;
+ users.users.stuebinm.openssh.authorizedKeys.keys = [
+ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIH8e9WrHsknoFwBm/YaigOSz9VI8dXRRR5G9BX4kKt9/ stuebinm@ilex"
+ ];
+
environment.systemPackages = with pkgs; [
- gnome3.gnome-tweaks
flatpak
# for mounting samba
cifs-utils
@@ -26,6 +30,7 @@
# networkmanager shouldn't handle nixos container
networkmanager.unmanaged = [ "interface-name:ve-*" ];
};
+
# nixos containers should have internet access
networking.nat = {
enable = true;