summaryrefslogtreecommitdiff
path: root/mindthegap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'mindthegap/Cargo.toml')
-rw-r--r--mindthegap/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/mindthegap/Cargo.toml b/mindthegap/Cargo.toml
new file mode 100644
index 0000000..7018d9d
--- /dev/null
+++ b/mindthegap/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "mindthegap"
+version = "0.1.0"
+edition = "2021"
+description = "Fetch information on Deutsche Bahn service interruptions"
+authors = ["stuebinm <stuebinm@disroot.org>"]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+reqwest = { version = "0.11", features = ["json", "cookies"] }
+tokio = { version = "1", features = ["full"] }
+serde_json = "1.0"
+serde = { version = "1.0", features = ["derive"] }
+owo-colors = "3"
+clap = { version = "3", features = [ "derive" ] }
+html-escape = "0.2.11"
+textwrap = "0.15"
+terminal_size = "0.2"
+ds100 = { path = "../ds100" }