aboutsummaryrefslogtreecommitdiff
path: root/stdlib/source/lux/type.lux (follow)
Commit message (Expand)AuthorAgeFilesLines
* Normalized the hierarchy of the standard library modules.Eduardo Julian2021-07-141-462/+0
* Re-named ":coerce" to ":as" since it technically doesn't do coercions.Eduardo Julian2021-07-111-11/+32
* "signature:" -> "interface:" & "structure:" -> "implementation:"Eduardo Julian2021-06-301-1/+1
* Got rid of the {}s in ":share" and made it pipe-able.Eduardo Julian2021-05-181-5/+7
* Almost done with PHP.Eduardo Julian2021-03-121-1/+3
* Improved compilation of loops and pattern-matching for Python. Eduardo Julian2021-02-011-5/+5
* Removed the (ultimately redundant) on_stop function for actors.Eduardo Julian2021-01-131-11/+0
* Encapsulate JS definitions produced by the JS compiler in a local scope to av...Eduardo Julian2021-01-111-4/+4
* Moved "log!" function under "lux/debug".Eduardo Julian2021-01-081-10/+11
* Moved "lux/data/number" to "lux/math/number".Eduardo Julian2020-12-291-2/+3
* Replaced kebab-case with snake_case for naming convention.Eduardo Julian2020-12-251-68/+68
* Better error messages when re-using a name when making a definition.Eduardo Julian2020-11-241-40/+40
* Made the syntax of ^template more consistent.Eduardo Julian2020-11-171-34/+34
* Re-named some list functions.Eduardo Julian2020-10-241-3/+3
* Re-named "to-text" functions to "format".Eduardo Julian2020-10-151-11/+11
* Gave the Location type its own module.Eduardo Julian2020-10-141-19/+34
* Re-named "Cursor" type to "Location".Eduardo Julian2020-10-071-6/+6
* Changed the format of project descriptor files.Eduardo Julian2020-09-161-10/+11
* Re-enabled lux/tool tests.Eduardo Julian2020-05-311-1/+3
* Local binding names for (co|indexed-)?monads are now explicitly set.Eduardo Julian2020-05-171-2/+2
* :share no longer relies on :assumeEduardo Julian2020-05-171-2/+1
* Parallel compilation for the new compiler(s).Eduardo Julian2020-05-161-5/+6
* No more "n/"-prefixed functions.Eduardo Julian2019-07-261-9/+9
* Implemented "hole" typing.Eduardo Julian2019-06-181-4/+17
* Introduced the "#Macro" type and got rid of the "#lux.macro?" annotation type...Eduardo Julian2019-05-021-38/+39
* Moved the code/syntax parser under "lux/control/parser/".Eduardo Julian2019-04-191-4/+5
* - Improved error messaging when trying to access an unbound type-parameter du...Eduardo Julian2019-04-171-108/+117
* Ported the analysis tests to the new format.Eduardo Julian2019-04-141-38/+40
* Created the "lux/abstract" branch and moved some modules into it.Eduardo Julian2019-04-061-2/+3
* Re-named "do-template" to "template".Eduardo Julian2019-03-301-4/+4
* Changed the convention for the structure opening separator from "/" to ";", t...Eduardo Julian2019-03-151-33/+33
* Re-named ":extract" to ":by-example".Eduardo Julian2019-03-121-3/+3
* Added the capacity to extract type-information from values to create new type...Eduardo Julian2019-03-021-0/+9
* Added the special # syntax for referring to the module's alias when opening s...Eduardo Julian2019-02-111-4/+4
* Changed the naming style for structures.Eduardo Julian2019-02-041-10/+8
* Some refactoring & minor additions.Eduardo Julian2018-12-261-3/+3
* Added contravariant functors.Eduardo Julian2018-12-251-0/+1
* Small improvements.Eduardo Julian2018-12-151-0/+1
* Method imports are now done as macros instead of functions.Eduardo Julian2018-08-291-1/+1
* No more escaping of new-line.Eduardo Julian2018-08-231-2/+2
* Moved "Array" type back into "lux/data/collection/array".Eduardo Julian2018-08-031-1/+2
* Removed temporary "|" prefix on Nat.Eduardo Julian2018-07-281-3/+3
* Temporary commit to get rid of "+" signs for Nat.Eduardo Julian2018-07-281-3/+3
* Re-named "seq" to "and" and "alt" to "or".Eduardo Julian2018-07-211-3/+3
* Re-named "Symbol" to "Identifier".Eduardo Julian2018-07-211-5/+5
* Re-named "Ident" to "Name".Eduardo Julian2018-07-211-6/+6
* Moved "lux/language/type/*" to "lux/type/*".Eduardo Julian2018-07-211-0/+391
* - Re-named "Lux" type to "Meta".Eduardo Julian2017-10-161-354/+0
* - Small refactorings.Eduardo Julian2017-10-111-0/+6
* - Changed the terminology of monoids ("append" -> "compose", "unit" -> "ident...Eduardo Julian2017-09-191-17/+17