aboutsummaryrefslogtreecommitdiff
path: root/stdlib/source/lux/data/number.lux (follow)
Commit message (Expand)AuthorAgeFilesLines
* Moved "lux/data/number" to "lux/math/number".Eduardo Julian2020-12-291-83/+0
* Replaced kebab-case with snake_case for naming convention.Eduardo Julian2020-12-251-13/+13
* Re-named "::" and ":::" macros to "\" and "\\", to be consistent with the con...Eduardo Julian2020-12-021-4/+4
* Re-named "Cursor" type to "Location".Eduardo Julian2020-10-071-2/+2
* Can now write TAR files.Eduardo Julian2020-05-191-2/+2
* Re-name "lux/data/error" to "lux/control/try".Eduardo Julian2019-07-021-19/+20
* Created the "lux/abstract" branch and moved some modules into it.Eduardo Julian2019-04-061-1/+1
* Changed the order of the inputs to the common extensions.Eduardo Julian2019-04-041-1/+1
* Re-named "do-template" to "template".Eduardo Julian2019-03-301-1/+1
* Now allowing the alias of a module to refer to the alias of an ancestor.Eduardo Julian2019-03-141-5/+5
* Replaced the digit separator in numbers from "_" to ",".Eduardo Julian2019-03-131-11/+11
* Changed the naming style for structures.Eduardo Julian2019-02-041-952/+9
* Some refactoring around the identity function.Eduardo Julian2019-02-031-34/+30
* No longer relying on "signature:"'s and "structure:"'s internal macro-expansi...Eduardo Julian2018-12-151-1/+0
* Re-named the "Error" tag to "Failure".Eduardo Julian2018-12-151-22/+22
* "lux text char" is now unsafe/optimized.Eduardo Julian2018-08-231-74/+80
* Optimized text clipping.Eduardo Julian2018-08-231-45/+39
* No more escaping of new-line.Eduardo Julian2018-08-231-3/+1
* No more escaping of double-quotes.Eduardo Julian2018-08-231-1/+1
* Fixed syntax bug.Eduardo Julian2018-08-201-2/+2
* Moved "Array" type back into "lux/data/collection/array".Eduardo Julian2018-08-031-1/+1
* Now implementing array functionality in stdlib instead of the compiler.Eduardo Julian2018-07-311-5/+7
* Now implementing math functionality in stdlib instead of the compiler.Eduardo Julian2018-07-301-12/+13
* Removed temporary "|" prefix on Nat.Eduardo Julian2018-07-281-173/+168
* Added "+" sign to positive Int.Eduardo Julian2018-07-281-119/+137
* Temporary commit to get rid of "+" signs for Nat.Eduardo Julian2018-07-281-160/+160
* No longer giving default aliases to un-prefixed imports.Eduardo Julian2018-07-201-5/+5
* - New syntax for bit values: "#0" and "#1", instead of "false" and "true".Eduardo Julian2018-07-141-9/+9
* Re-named "Bool" type to "Bit".Eduardo Julian2018-07-131-5/+5
* - Re-named "lux/data/bit" to "lux/data/number/i64".Eduardo Julian2018-07-131-22/+23
* - Got rid of "lux text replace-once" and "lux text replace-all" extensions.Eduardo Julian2018-07-111-4/+5
* - Improvements to import syntax [part 2].Eduardo Julian2018-07-111-12/+14
* - Improvements to import syntax [part 0].Eduardo Julian2018-07-101-3/+3
* - Re-named "struct:" to "structure:".Eduardo Julian2018-07-101-19/+19
* - Re-named "equality" to "equivalence".Eduardo Julian2018-07-051-10/+10
* - Re-named "degree" to "revolution".Eduardo Julian2018-07-041-40/+40
* - Implemented not-a-number and both infinities in pure Lux.Eduardo Julian2018-07-041-5/+5
* - Re-named ":!" to ":coerce".Eduardo Julian2018-07-031-16/+16
* - Migrated Scheme back-end to stdlib.Eduardo Julian2018-06-171-3/+3
* - Re-named "Top" to "Any", and "Bottom" to "Nothing".Eduardo Julian2018-05-201-3/+3
* - Re-named ".../eq" modules to ".../equality".Eduardo Julian2018-05-131-1/+1
* - Added new #I64 type as foundation for types based on 64-bit integers.Eduardo Julian2018-05-131-79/+79
* - Implemented Deg functionality in pure Lux.Eduardo Julian2018-05-071-5/+5
* - Implemented Nat functionality in pure Lux.Eduardo Julian2018-05-061-1/+1
* - Re-named shift-left -> left-shift, shift-right -> logical-right-shift, sign...Eduardo Julian2018-05-061-5/+5
* - Removed "lux text upper" and "lux text lower" procedures.Eduardo Julian2018-05-061-40/+149
* - Allow underscore separators in the hex, octal and binary encoding macros fo...Eduardo Julian2018-05-011-29/+60
* - Changed the identifier separator, from the semi-colon (;) to the period/dot...Eduardo Julian2017-11-291-109/+109
* - Re-named the "." function to "compose" and moved it to lux/function.Eduardo Julian2017-11-281-1/+1
* - Got rid of even more dots.Eduardo Julian2017-11-271-1/+1