aboutsummaryrefslogtreecommitdiff
path: root/stdlib/source/lux.lux (follow)
Commit message (Collapse)AuthorAgeFilesLines
* Normalized the hierarchy of the standard library modules.Eduardo Julian2021-07-141-5953/+0
|
* Better syntax for parallel-hierarchy imports.Eduardo Julian2021-07-121-41/+63
|
* Re-named ":coerce" to ":as" since it technically doesn't do coercions.Eduardo Julian2021-07-111-121/+125
|
* Made the "try" macro into a common one, instead of a host-specific one.Eduardo Julian2021-07-101-0/+18
|
* "signature:" -> "interface:" & "structure:" -> "implementation:"Eduardo Julian2021-06-301-19/+19
| | | "signature" & "structure" feel like very ML-specific terminology and might not be easy on programmers unfamiliar with it.
* Some updates for the new compilers.Eduardo Julian2021-06-291-17/+12
|
* More adjustments for Common Lisp.Eduardo Julian2021-05-301-246/+268
|
* Using offset+distance instead of from+to for text clipping.Eduardo Julian2021-05-241-2/+2
|
* Wrestling with JPHP.Eduardo Julian2021-03-101-5/+16
|
* Done with Ruby.Eduardo Julian2021-03-011-0/+2
|
* Continuing with LuaEduardo Julian2021-02-101-9/+16
|
* Mo' updates, less problems.Eduardo Julian2021-02-071-1/+1
|
* Implemented arithmetic right-shift in terms of logic right-shift.Eduardo Julian2021-01-281-2/+2
|
* Moved "log!" function under "lux/debug".Eduardo Julian2021-01-081-8/+0
|
* Unified repository abstraction for Aedifex.Eduardo Julian2020-12-291-1/+1
|
* Moved "lux/data/number" to "lux/math/number".Eduardo Julian2020-12-291-45/+45
|
* Replaced kebab-case with snake_case for naming convention.Eduardo Julian2020-12-251-1367/+1367
|
* Properly naming unicode Block type.Eduardo Julian2020-12-221-1/+1
|
* Re-named old luxc-jvm to lux-bootstrapper.Eduardo Julian2020-12-041-2/+2
|
* Re-named "::" and ":::" macros to "\" and "\\", to be consistent with the ↵Eduardo Julian2020-12-021-10/+10
| | | | convention that only macros that deal with types may start with a colon.
* Added specialized root/2 and root/3 functions in lux/math.Eduardo Julian2020-12-011-387/+387
|
* Better error messages when re-using a name when making a definition.Eduardo Julian2020-11-241-2/+2
|
* Made the syntax of ^template more consistent.Eduardo Julian2020-11-171-73/+75
|
* Lightweight machinery for agent-oriented programming.Eduardo Julian2020-11-051-12/+9
|
* Re-named some list functions.Eduardo Julian2020-10-241-14/+14
|
* Re-named "to-text" functions to "format".Eduardo Julian2020-10-151-4/+4
|
* Gave the Location type its own module.Eduardo Julian2020-10-141-10/+1
|
* Re-named "Cursor" type to "Location".Eduardo Julian2020-10-071-172/+172
|
* Fixes and improvements to JavaScript compilation.Eduardo Julian2020-07-101-60/+20
|
* Now using the new syntax for variants (even though they still work the old ↵Eduardo Julian2020-07-021-133/+133
| | | | way... for now)
* The "for" macro can now work directly with definitions. No text literals ↵Eduardo Julian2020-06-281-25/+43
| | | | necessary.
* Updated test for function optimization.Eduardo Julian2020-06-111-1/+1
|
* Parallel compilation for the new compiler(s).Eduardo Julian2020-05-161-22/+34
|
* Loading the artifacts from the cache and re-populating the analyser's state.Eduardo Julian2020-05-061-7/+7
|
* Fixed bugs while parsing modules' cached data.Eduardo Julian2020-05-051-2/+2
|
* Added some testing machinery to measure the code coverage of tests.Eduardo Julian2020-04-201-18/+18
|
* Tests for JVM bytecode machinery. [Part 5]Eduardo Julian2019-11-161-1/+3
|
* Added the ":let" macro to enable reuse of type fragments in larger types.Eduardo Julian2019-09-151-4/+19
|
* No more "n/"-prefixed functions.Eduardo Julian2019-07-261-119/+59
|
* No more "i/"-prefixed functions.Eduardo Julian2019-07-251-82/+23
|
* No more "r/"-prefixed functions.Eduardo Julian2019-07-241-135/+7
|
* No more "f/"-prefixed functions.Eduardo Julian2019-07-241-78/+3
| | | + No more "m/"-prefixed functions.
* Removed the (magical) "alias" annotations tag.Eduardo Julian2019-06-011-29/+65
|
* Applied several tweaks to make the code easier to process by the new compiler.Eduardo Julian2019-05-281-9/+23
|
* Removed the (magical) "export?" annotations tag.Eduardo Julian2019-05-241-268/+256
|
* Removed the (magical) "tags" annotations tag.Eduardo Julian2019-05-221-400/+320
|
* Removed the (magical) "imports" annotations tag.Eduardo Julian2019-05-221-220/+251
|
* Removed the useless #lux.type? annotation tag.Eduardo Julian2019-05-221-142/+97
|
* Introduced the "#Macro" type and got rid of the "#lux.macro?" annotation ↵Eduardo Julian2019-05-021-136/+125
| | | | type and its "magical" compiler behavior.
* Turned all "lux int ???" extensions to "lux i64 ???".Eduardo Julian2019-04-281-22/+22
|