aboutsummaryrefslogtreecommitdiff
path: root/source/lux/codata/stream.lux (follow)
Commit message (Collapse)AuthorAgeFilesLines
* - Removed the Lux source from the repo, as it now belongs to the lux/stdlib ↵Eduardo Julian2015-10-041-140/+0
| | | | | | package. - Removed de Apacke Commons Compress library, as Lux libraries will now be packaged as .jar files instead of as .tar.gz files. - The compiler no longer packages libraries, as that task will now be left for the build system.
* - Changed the name of the \stream macro to \stream&Eduardo Julian2015-09-161-7/+7
|
* - :: no longer demands prefixes for the struct membersEduardo Julian2015-09-151-11/+20
| | | - Fixed both lux/control/comonad;be & lux/codata/stream;\stream
* - Updated the standard library.Eduardo Julian2015-09-111-1/+1
|
* - Removed the (unnecessary) lux/meta/macro module.Eduardo Julian2015-09-061-1/+0
|
* - Found a compromise with the issue of certain definitions clashing with ↵Eduardo Julian2015-08-311-6/+6
| | | | each other when saving the class files in case-insensitive file-systems (https://github.com/LuxLang/lux/issues/8). The names of certain definitions were changed slightly to avoid clashes and the compiler throws an error if the names end up clashing prior to saving the .class file.
* - Remove the (unnec) "All'" and "->'" macros.Eduardo Julian2015-08-291-4/+4
| | | | - Improved the "struct" macro so that (once again) it doesn't ask for the prefixes of the members. - Added tests for the lux.reader namespace.
* - Added some compiler optimizations.Eduardo Julian2015-08-291-1/+1
| | | | - Removed the (unnecessary) lux/control/dict & lux/control/stack modules. - The "Meta" type is now a record instead of a variant.
* - Changed the name of AllT (for-all type) to UnivQ (universal quantification).Eduardo Julian2015-08-281-4/+4
| | | | - UnivQ no longer stores the environment as key-val pairs with Text names, but instead stores it as type-lists with variables accessed via an index through a (updated) BoundT. - UnivQ no longer stores the name of the type-fun, not the name of the type-arg.
* Changed the license from EPL to MPL.Eduardo Julian2015-08-281-7/+4
|
* - Finished turning tags into indices.Eduardo Julian2015-08-171-4/+4
| | | | | | | - As an unexpected bonus, the compiler has become 2.5x faster. - Fixed some minor bugs. - Tag declarations now include associated types. - Tag declarations info is now stored twice (one from the perspective of tags, the other from the perspective of types). - Changed the named of the "types" member of the Compiler type, to "type-vars" to avoid collision with the "types" member of the Module type.
* - Local vars can now longer have prefixed symbols.Eduardo Julian2015-08-051-1/+1
|
* - Struct definition no longer required prefixed members (now, it actually ↵Eduardo Julian2015-08-041-5/+5
| | | | prohibits them).
* - Renamed the Syntax type to AST.Eduardo Julian2015-08-041-1/+1
| | | - Created the lux/meta/ast module.
* - Added a module for hashing.Eduardo Julian2015-08-021-1/+2
| | | | | | | | - Refactored the standard library a bit. - Implemented the "loop" macro. - Added the expected type of expressions as a field in the compiler state. - Added syntactic sugar for using tuples with variants, in order to minimize the usage of brackets to delimit the contents of data-structures. - Fixed a bug wherein "macro-expand" was behaving like "macro-expand-all", and added a separate implementation for "macro-expand-all". - Fixed a few bugs.
* - Did some refactoring of the standard library.Eduardo Julian2015-07-311-5/+6
| | | | | | | | - Introduced 2 new modules: lux/data/tuple & lux/codata/function - Now doing safe reading of files. - Took the "let", "lambda" & "def" macros to their ultimate form. - Added some macros for doing better JVM interop. - Fixed a bug when compiling comparisons for doubles. - Changed the order in which arguments are compiled for all arithmetic operations, as the order is reversed (from the conventional order) in the JVM bytecode.
* - The output directory is now being used as the cache.Eduardo Julian2015-07-251-0/+133
- "input" has been renamed as "source" and "output" has been renamed as "target".