summaryrefslogtreecommitdiff
path: root/isabelle-unicode/Cargo.toml
diff options
context:
space:
mode:
authorstuebinm2021-09-02 23:31:39 +0200
committerstuebinm2021-09-03 00:02:16 +0200
commitad514f56b6cda288e605c44990ef16d30e6dee53 (patch)
treebec6de5f4bdabf432c7045394af15ba96f525546 /isabelle-unicode/Cargo.toml
parent715001ba92799839afc97d92c9f0a79924085a69 (diff)
remove grmtools
the parser using grmtools was way oversized for just doing escape sequences, and only really existed since I wanted to play around with it. The new implementation depends on no external crates, uses just an iter wrapped into a nicely composable function, and appears to be exactly equivalent (but faster).
Diffstat (limited to 'isabelle-unicode/Cargo.toml')
-rw-r--r--isabelle-unicode/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/isabelle-unicode/Cargo.toml b/isabelle-unicode/Cargo.toml
new file mode 100644
index 0000000..2e5ff9f
--- /dev/null
+++ b/isabelle-unicode/Cargo.toml
@@ -0,0 +1,10 @@
+[package]
+name = "isabelle-unicode"
+version = "0.1.0"
+authors = ["stuebinm <stuebinm@disroot.org>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+symbolmacro = { path = "../symbolmacro" }