summaryrefslogtreecommitdiff
path: root/isabat.nix
diff options
context:
space:
mode:
authorstuebinm2021-09-04 16:43:19 +0200
committerstuebinm2021-09-04 16:43:19 +0200
commit3d7cd5018144c4c7b3a95ae7a1953445f6b25fa7 (patch)
tree6fe64122c01b6ee4efae7cb51d821f922bc2790e /isabat.nix
parent86ab660002443f940abc392cf4beab5172568887 (diff)
restructure nix stuff
There's now a packageset in default.nix, and individual files for the rust and shell script stuff.
Diffstat (limited to 'isabat.nix')
-rw-r--r--isabat.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/isabat.nix b/isabat.nix
index 8d00447..711c8c3 100644
--- a/isabat.nix
+++ b/isabat.nix
@@ -1,8 +1,4 @@
-let
- sources = import ./nix/sources.nix;
- pkgs = import sources.nixpkgs {};
- isabelle-unicode = import ./default.nix;
-in
+{pkgs, isabelle-rust-utils}:
with pkgs;
stdenv.mkDerivation {
@@ -16,7 +12,7 @@ stdenv.mkDerivation {
buildPhase = ''
cp $src isabat
substituteInPlace isabat \
- --replace isabelle2unicode "${isabelle-unicode}/bin/isabelle2unicode"
+ --replace isabelle2unicode "${isabelle-rust-utils}/bin/isabelle2unicode"
substituteInPlace isabat \
--replace " bat " " ${pkgs.bat}/bin/bat "
mkdir -p $out/bin