summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorstuebinm2021-09-04 16:43:19 +0200
committerstuebinm2021-09-04 16:43:19 +0200
commit3d7cd5018144c4c7b3a95ae7a1953445f6b25fa7 (patch)
tree6fe64122c01b6ee4efae7cb51d821f922bc2790e /default.nix
parent86ab660002443f940abc392cf4beab5172568887 (diff)
restructure nix stuff
There's now a packageset in default.nix, and individual files for the rust and shell script stuff.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix21
1 files changed, 15 insertions, 6 deletions
diff --git a/default.nix b/default.nix
index 964a95a..f807fa6 100644
--- a/default.nix
+++ b/default.nix
@@ -1,8 +1,17 @@
let
- sources = import ./nix/sources.nix;
- pkgs = import sources.nixpkgs {};
- naersk = pkgs.callPackage sources.naersk {};
-in naersk.buildPackage {
- name = "isabelle-unicode";
- src = ./.;
+ sources = import ./nix/sources.nix;
+in
+
+{ pkgs ? import sources.nixpkgs {}
+, naersk ? pkgs.callPackage sources.naersk {}
+, ... }:
+
+rec {
+ isabelle-rust-utils = import ./crates.nix {
+ inherit pkgs naersk;
+ };
+
+ isabat = import ./isabat.nix {
+ inherit pkgs isabelle-rust-utils;
+ };
}