Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Rename dhall_core to dhall_syntax | Nadrieril | 2019-05-04 | 10 | -3050/+0 |
| | |||||
* | Update dhall-lang submodule | Nadrieril | 2019-05-02 | 2 | -5/+46 |
| | |||||
* | Update dhall-lang submodule | Nadrieril | 2019-05-02 | 1 | -71/+51 |
| | |||||
* | Update dhall-lang submodule | Nadrieril | 2019-05-02 | 2 | -3/+8 |
| | |||||
* | Update dhall-lang submodule | Nadrieril | 2019-05-02 | 2 | -26/+41 |
| | |||||
* | Remove shift0 | Nadrieril | 2019-05-02 | 1 | -23/+17 |
| | |||||
* | Fix shifting. This completely destroys sharing so performance is dead. | Nadrieril | 2019-04-30 | 1 | -1/+3 |
| | |||||
* | Don't shift by mutable ref | Nadrieril | 2019-04-29 | 1 | -7/+19 |
| | |||||
* | Properly substitute when typing App | Nadrieril | 2019-04-29 | 1 | -8/+15 |
| | |||||
* | Remove now obsolete subst_shift | Nadrieril | 2019-04-22 | 1 | -42/+1 |
| | |||||
* | Prepare for interop between two contexts | Nadrieril | 2019-04-21 | 1 | -13/+21 |
| | |||||
* | An empty optional value is purely semantic | Nadrieril | 2019-04-20 | 4 | -14/+6 |
| | |||||
* | Implement more normalization simplifications | Nadrieril | 2019-04-20 | 1 | -27/+24 |
| | |||||
* | improved_slice_patterns now returns ownership on error | Nadrieril | 2019-04-20 | 2 | -2/+2 |
| | |||||
* | Text interpolation | Nadrieril | 2019-04-20 | 1 | -4/+4 |
| | |||||
* | Text literals | Nadrieril | 2019-04-20 | 1 | -2/+14 |
| | |||||
* | A union constructor is a purely semantic value | Nadrieril | 2019-04-19 | 3 | -15/+0 |
| | |||||
* | Make App() only store one argument | Nadrieril | 2019-04-19 | 4 | -16/+7 |
| | |||||
* | Label is redundant in EnvItem::Skip | Nadrieril | 2019-04-18 | 1 | -2/+4 |
| | |||||
* | Use a context for substitution in normalization | Nadrieril | 2019-04-18 | 1 | -1/+7 |
| | |||||
* | subst_shift in a single pass | Nadrieril | 2019-04-18 | 2 | -5/+71 |
| | |||||
* | Use argument-position impl trait for mapping functions | Nadrieril | 2019-04-18 | 1 | -87/+39 |
| | |||||
* | Remove more duplication | Nadrieril | 2019-04-18 | 2 | -62/+34 |
| | |||||
* | Avoid an unnecessary unroll() | Nadrieril | 2019-04-18 | 2 | -27/+52 |
| | |||||
* | Add even more general visitor trait | Nadrieril | 2019-04-18 | 1 | -55/+140 |
| | |||||
* | Reduce duplication between mapping functions | Nadrieril | 2019-04-18 | 2 | -58/+33 |
| | |||||
* | Deprecate some things | Nadrieril | 2019-04-18 | 2 | -21/+6 |
| | |||||
* | Merge impl blocks | Nadrieril | 2019-04-18 | 1 | -106/+104 |
| | |||||
* | Consistent type variable naming | Nadrieril | 2019-04-18 | 1 | -33/+34 |
| | |||||
* | Start cleaning up the mess of mapping functions | Nadrieril | 2019-04-18 | 2 | -23/+130 |
| | |||||
* | Simplify implementation of shift and subst_shift | Nadrieril | 2019-04-18 | 1 | -27/+31 |
| | |||||
* | Normalize union constructors | Nadrieril | 2019-04-17 | 3 | -4/+19 |
| | |||||
* | rustfmt | Nadrieril | 2019-04-16 | 1 | -1/+2 |
| | |||||
* | Update dhall-lang submodule | Nadrieril | 2019-04-16 | 1 | -6/+11 |
| | |||||
* | Tiny rename to save myself a lot of pain | Nadrieril | 2019-04-16 | 1 | -27/+27 |
| | |||||
* | Handle nullary union variants | Nadrieril | 2019-04-16 | 1 | -1/+8 |
| | | | | Closes #36 | ||||
* | Prepare for nullary union variants | Nadrieril | 2019-04-16 | 4 | -21/+51 |
| | |||||
* | Fix union constructor typechecking | Nadrieril | 2019-04-16 | 1 | -0/+6 |
| | |||||
* | Doc tweak | Nadrieril | 2019-04-16 | 1 | -8/+8 |
| | |||||
* | Handle empty optionals correctly | Nadrieril | 2019-04-15 | 4 | -6/+18 |
| | | | | Closes #78 | ||||
* | Remove leftover bx() function | Nadrieril | 2019-04-15 | 1 | -6/+1 |
| | |||||
* | clippy | Nadrieril | 2019-04-14 | 2 | -3/+3 |
| | |||||
* | Use crates.io improved_slice_patterns on top of path dep | Nadrieril | 2019-04-14 | 1 | -1/+1 |
| | |||||
* | Rename iter_patterns to improved_slice_patterns | Nadrieril | 2019-04-14 | 2 | -2/+2 |
| | |||||
* | Document roughly the dhall subcrates | Nadrieril | 2019-04-14 | 1 | -0/+5 |
| | | | | Closes #72 | ||||
* | Use upstream pest | Nadrieril | 2019-04-14 | 1 | -1/+1 |
| | |||||
* | Merge pull request #68 from basile-henry/cache-imports | Nadrieril Feneanar | 2019-04-14 | 1 | -8/+8 |
|\ | | | | | Cache imports | ||||
| * | Cache imports | Basile Henry | 2019-04-14 | 1 | -8/+8 |
| | | |||||
* | | Document why Visitor is needed | Nadrieril | 2019-04-14 | 1 | -0/+12 |
|/ | |||||
* | Remove unused ExprF::as_ref | Nadrieril | 2019-04-14 | 1 | -47/+0 |
| |