summaryrefslogtreecommitdiff
path: root/dhall_core (follow)
Commit message (Expand)AuthorAgeFilesLines
* Rename dhall_core to dhall_syntaxNadrieril2019-05-0410-3050/+0
* Update dhall-lang submoduleNadrieril2019-05-022-5/+46
* Update dhall-lang submoduleNadrieril2019-05-021-71/+51
* Update dhall-lang submoduleNadrieril2019-05-022-3/+8
* Update dhall-lang submoduleNadrieril2019-05-022-26/+41
* Remove shift0Nadrieril2019-05-021-23/+17
* Fix shifting. This completely destroys sharing so performance is dead.Nadrieril2019-04-301-1/+3
* Don't shift by mutable refNadrieril2019-04-291-7/+19
* Properly substitute when typing AppNadrieril2019-04-291-8/+15
* Remove now obsolete subst_shiftNadrieril2019-04-221-42/+1
* Prepare for interop between two contextsNadrieril2019-04-211-13/+21
* An empty optional value is purely semanticNadrieril2019-04-204-14/+6
* Implement more normalization simplificationsNadrieril2019-04-201-27/+24
* improved_slice_patterns now returns ownership on errorNadrieril2019-04-202-2/+2
* Text interpolationNadrieril2019-04-201-4/+4
* Text literalsNadrieril2019-04-201-2/+14
* A union constructor is a purely semantic valueNadrieril2019-04-193-15/+0
* Make App() only store one argumentNadrieril2019-04-194-16/+7
* Label is redundant in EnvItem::SkipNadrieril2019-04-181-2/+4
* Use a context for substitution in normalizationNadrieril2019-04-181-1/+7
* subst_shift in a single passNadrieril2019-04-182-5/+71
* Use argument-position impl trait for mapping functionsNadrieril2019-04-181-87/+39
* Remove more duplicationNadrieril2019-04-182-62/+34
* Avoid an unnecessary unroll()Nadrieril2019-04-182-27/+52
* Add even more general visitor traitNadrieril2019-04-181-55/+140
* Reduce duplication between mapping functionsNadrieril2019-04-182-58/+33
* Deprecate some thingsNadrieril2019-04-182-21/+6
* Merge impl blocksNadrieril2019-04-181-106/+104
* Consistent type variable namingNadrieril2019-04-181-33/+34
* Start cleaning up the mess of mapping functionsNadrieril2019-04-182-23/+130
* Simplify implementation of shift and subst_shiftNadrieril2019-04-181-27/+31
* Normalize union constructorsNadrieril2019-04-173-4/+19
* rustfmtNadrieril2019-04-161-1/+2
* Update dhall-lang submoduleNadrieril2019-04-161-6/+11
* Tiny rename to save myself a lot of painNadrieril2019-04-161-27/+27
* Handle nullary union variantsNadrieril2019-04-161-1/+8
* Prepare for nullary union variantsNadrieril2019-04-164-21/+51
* Fix union constructor typecheckingNadrieril2019-04-161-0/+6
* Doc tweakNadrieril2019-04-161-8/+8
* Handle empty optionals correctlyNadrieril2019-04-154-6/+18
* Remove leftover bx() functionNadrieril2019-04-151-6/+1
* clippyNadrieril2019-04-142-3/+3
* Use crates.io improved_slice_patterns on top of path depNadrieril2019-04-141-1/+1
* Rename iter_patterns to improved_slice_patternsNadrieril2019-04-142-2/+2
* Document roughly the dhall subcratesNadrieril2019-04-141-0/+5
* Use upstream pestNadrieril2019-04-141-1/+1
* Merge pull request #68 from basile-henry/cache-importsNadrieril Feneanar2019-04-141-8/+8
|\
| * Cache importsBasile Henry2019-04-141-8/+8
* | Document why Visitor is neededNadrieril2019-04-141-0/+12
|/
* Remove unused ExprF::as_refNadrieril2019-04-141-47/+0