aboutsummaryrefslogtreecommitdiff
path: root/nix/tests/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/tests/common.nix')
-rw-r--r--nix/tests/common.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nix/tests/common.nix b/nix/tests/common.nix
index 37abb5d..9e5f363 100644
--- a/nix/tests/common.nix
+++ b/nix/tests/common.nix
@@ -2,11 +2,12 @@
#
# SPDX-License-Identifier: MPL-2.0
-{inputs, pkgs, ...}: {
+{inputs, pkgs, flakes, ...}: {
nix = {
registry.nixpkgs.flake = inputs.nixpkgs;
+ nixPath = [ "nixpkgs=${inputs.nixpkgs}" ];
extraOptions = ''
- experimental-features = nix-command flakes
+ experimental-features = ${if flakes then "nix-command flakes" else "nix-command"}
'';
settings = {
trusted-users = [ "root" "@wheel" ];